Специальные и частные IPv4 адреса

Частные адреса

Блоками частных адресов являются (RFC1918 Address Allocation for Private Internets):
  • 10.0.0.0/8 (10.0.0.0 - 10.255.255.255)
  • 172.16.0.0/12 (172.16.0.0 - 172.31.255.255)
  • 192.168.0.0/16 (192.168.0.0 - 192.168.255.255)

Специальные адреса

  • Адреса loopback (127.0.0.0 /8 или от 127.0.0.1 до 127.255.255.254)
  • Локальные адреса канала (169.254.0.0 /16 или от 169.254.0.1 до 169.254.255.254) более известны как адреса, назначаемые посредством автоматического назначения частных IP-адресов (Automatic Private IP Addressing, APIPA). Они используются в небольшой одноранговой сети или клиентом Windows DCHP для самостоятельной конфигурации в случае, если ни один DHCP-сервер не доступен. 
  • Адреса TEST-NET (192.0.2.0/24 или от 192.0.2.0 до 192.0.2.255) используются исключительно в целях обучения и могут использоваться в качестве примера для документирования при создании сетей.
Устаревший RFC3330 Special-Use IPv4 Addresses: "В блоке адресов от 240.0.0.0 до 255.255.255.254 имеются экспериментальные адреса"

RFC6890 Special-Purpose IP Address Registries

RFC6598 IANA-Reserved IPv4 Prefix for Shared Address Space

IPv4 Multicast

Многоадресная рассылка

Зарезервированы адреса: 224.0.0.0/4 (224.0.0.0-239.255.255.255)

224.0.0.0/24 - в пределах локальной сети

224.0.0.9 - RIPv2

"Каждая группа многоадресной рассылки представлена одним групповым IPv4-адресом назначения. Когда IPv4-узел подписывается на группу многоадресной рассылки, он обрабатывает пакеты, адресованные на этот групповой адрес, а также пакеты, адресованные на его уникальный индивидуальный адрес."

Шпаргалка ImageMagick

Есть pdf-ка с картинками. Надо сделать "плакат" на А1.

Конвертация страниц pdf в изображения jpg:

convert -density 72 file.pdf RA9FWB.jpg

Объединение изображений (создание коллажа)

montage RA9FWB-* -geometry 720x540 RA9FWB.png
или
montage RA9FWB-* -geometry 720x540 RA9FWB.jpg
-geometry задаёт размер в пикселях каждого изображения.

Получилось:
.png (37 МБ)
.jpg (3 МБ)

Локальный сервер обновления Debian

Ещё одна мини-памятка, теперь про создание локального зеркала репозиториев, актуальна для Debian Wheezy, описывается момент, на котором пришлось задуматься - раздача пакетов. Теперь оно работает, однако, вполне возможно, есть лучшие и более правильные способы решение этой задачи. Буду рад критике.

0. Необязательное введение

Однажды захотелось странного - перевести наконец-то компьютерный класс (14 стареньких Core2Duo) на линукс. 1ГБ рам - особо не навиртуализируешься. Ведутся там в основном операционки, компьютерные сети и алгоритмизация и программирование.

Установка - силами студентов в качестве лабораторных работ. Ставили CentOS (тогда ещё 6), теперь стоит по заголовку - Debian Wheezy.

Настройка/управление - Ansible, возможно, будет SaltStack, но это уже другая история. Посмотрим на локальный репозиторий.

1.  Создание зеркала с помощью apt-mirror

Создаём его с помощью apt-mirror. Двум статьям за это большое спасибо: https://wiki.debian.org/ru/CreateLocalRepo и http://mydrafts.ru/debian-sozdanie-lokalnogo-repozitoriya-apt-mirror/. Ниже будут отличия от этих статей.

Важное из конфига /etc/apt/mirror.list:
set base_path    /mnt/repo/debian
# Зеркало с пакетами wheezy x64
deb-amd64 ftp://debian.nsu.ru/debian wheezy main contrib non-free
# Зеркало с обновлениями безопасности wheezy x64
deb-amd64 http://security.debian.org/ wheezy/updates main contrib non-free
set base_path - репозитории хранятся на отдельном разделе, монтирующемся в /mnt/repo/, загружаются в debian/.
Зеркала для скачивания репозиториев - debian.nsu.ru и security.debian.org.

С чувством глубокого удовлетворения запускаем
# apt-mirror
Ждём загрузки 40+ ГБ и думаем, что же делать дальше.

2. Настройка веб-сервера (nginx)

А дальше по структуре файлов видим, что нужно предоставить доступ к двум появившимся каталогам:
  • /mnt/repo/debian/mirror/debian.nsu.ru/debian/ (в котором есть подкаталог dists/wheezy/)
  • /mnt/repo/debian/mirror/security.debian.org/ (в котором есть подкаталог dists/wheezy/updates/)
Сделать это можно с помощью nginx (или любым другим сервером, но я воспользовался именно им), у которого должен быть доступ на чтение к этим каталогам. Минимальная конфигурация nginx:
http {
        server {
                location / {
                        root /srv/http;
                        autoindex on;
                }
        }
}
Здесь autoindex on; позволяет отдавать файлы из каталога. В каталоге /srv/http создаём две символические ссылки debian и debian-security:
# ln -s /mnt/repo/debian/mirror/debian.nsu.ru/debian/ /srv/http/debian
# ln -s /mnt/repo/debian/mirror/security.debian.org/ /srv/http/debian-security

3. Настройка apt-get на клиентах

Теперь осталось настроить доступ к этим двум репозиториям на клиентах.

Конфиг /etc/apt/sources.list:
deb http://127.0.0.1/debian wheezy main contrib non-free
deb http://127.0.0.1/debian-security wheezy/updates main contrib non-free

В консоли клиентов:
# apt-get upgrade
# apt-get update

Вот, собственно, и всё. Конечно, остались некоторые непонятные мне моменты, но, как обычно, появились срочные дела, а обновление работает, пришлось успокоиться. Подскажете, как лучше сделать - моя благодарность. Есть непонятные вещи? Спрашивайте, подскажу, что смогу :)

Archlinux, wmii и приличное оформление

UPD: На самом деле, всё есть здесь: https://awesome.naquadah.org/wiki/Customizing_GTK_Apps/ru#Автоматизация

Как-то вдруг обратил внимание, что на одном компе firefox - лисица как лисица, а на другом она какая-то квадратная и сероватая, хотя конфигурации примерно одинаковы.

Archlinux с wmii в качестве основного оконного менеджера не радует оформлением, пока не будут установлены, например, стандартные темы гнома:
pacman -S gnome-themes-standard
За собой он тянет в зависимостях cantarell-fonts.